• 📝Note

    Notre forum se distingue de la concurence autant par son accueil courtois que par son riche contenu qu'il présente.
    Si vous avez l'intention de vous inscrire et de rejoindre notre communauté, sachez que le contenu du forum sera invisible pour les membres non présentés (0 posteur) ou non encore approuvés !
    De plus, si votre objectif est de ne pas vous présenter, sachez que votre compte sera supprimé dans les 48 heures suivantes votre inscription afin d'éviter d'encombrer inutilement notre base de données.

    ⚠️Avertissement
    L'utilisation d'un VPN ou d'un Proxy est prohibé lors de votre inscription.
    Le but est de protéger notre communauté d'individus malveillants ou indésirables.
    Toute inscription derrière un Proxy ou VPN sera rejetée en tant que SPAM !

Résolu Petit Soucis avec un Tableau excel

Domtous

Dominique
Membre VIP
Membre
Bonjour,

j'ai un petit soucis avec une formule ou plutot quand je veux remplir en automatique avec la poignet de remplissage (coin inférieur droit d'une cellule)

voilà la formule: =SI(B43="";"";Glaspull!H23) et quand je la tire elle me fait =SI(B44="";"";Glaspull!H24) et =SI(B45="";"";Glaspull!H25)
alors que moi je voudrais : =SI(B43="";"";Glaspull!H23) et =SI(B44="";"";Glaspull!H23) et =SI(B45="";"";Glaspull!H23)

alors quelqu'un aurait une idée

 
Dernière édition:
Effectivement Domtous, le "#" ne solutionne pas ton cas, c'est pour cette raison que j'ai modifié ma réponse initiale
Tu dois utiliser le "$"
Exemple
H$23 si tu fixe la ligne 23
$H23 si tu fixe la colonne H
$H$23 si tu fixe la cellule H23
 
Re bonjour,

Voilà un autre problème Excel toujours sur le même tableau
donc Glaspull!$H$23 me donne un résultat
Aujourd'hui (7/09/2020), je rentre des valeurs dans ce tableau et j'enregistre ces données
Demain (8/09/2020), j'ouvre ce même fichier enregistrer la veille , donc jusque là tout va bien. Je change la valeur Glaspull!$H$23 et là les résultats du 7/09/2020 change.

Comment puis-je garder ces résultats du 7/09/2020 alors que Glaspull!$H$23 à changer. il faut savoir que j'ai protégé la feuille pour éviter les mauvaises manipulations

j'espère que je me suis bien fait comprendre :)
 
Bonjour Domtous,
Il est impossible de répondre à ta question.
Si des valeurs changent en fonction d'une date, c'est qu'il y a dans ton tableau une formule ou une macros qui prend en compte cette variable.
Te dire laquelle et ou elle se trouve sans le fichier excel, cela relève de la voyance.
 
Merci de ta réponse

non les valeurs ne change pas par rapport à une date, c'est moi qui décide de changer la valeur Glaspull!$H$23 pour des raison spécifique (quantité n'est plus la même)

moi ce que je veux c'est enregistrée cette feuille et pouvoir la récupérer un jour ou 1 heure plus-tard avec les résultats sauvegardées et pouvoir changer Glaspull!$H$23 sans que cela change la sauvegarde faite 1 jour avant ou 1 heure avant (enregistrement automatique)
 
Forcément...
Si aujourd'hui tu crée ton fichier en introduisant des valeurs spécifiques et que tu les sauves
Si demain du ré-ouvre ce même fichier avec les valeurs du jour précédent.
Mais si tu les modifies et que tu re-sauve ton fichier modifié... Il écrasera l'ancien (avec les anciennes valeurs)

Solution:
Lundi- Tu ouvre ton fichier initial - Tu introduit les valeurs de lundi - Tu sauve en spécifiant un nom de fichier spécifique à lundi.
Mardi- Tu ouvre ton fichier initial - Tu introduit les valeurs de Mardi - Tu sauve en spécifiant un nom de fichier spécifique à Mardi.
et ainsi de suite.
Cette solution n'est serte pas pratique mais fonctionne.

Pour toute autre solution,
Il faudrait que tu donne quelque explication complémentaire et que je dispose du fichier initial.
-----------------------------------------------------------
En france, il me semble que vos compteurs sont liés au fournisseur et que le type de contrat est subordonné à une puissance théorique. Donc je suppose que ta demande est lié d'une manière ou d'une autre au rapport Puissance/Consommation.
 
Qui a lu ce fil (Lecteurs totaux : 0)
Aucun utilisateur enregistré ne consulte ce fil.

Un don pour TE

Campagne 2024

Aidez-nous à financer l'hébergement
Objectif
325.00 €
Reçu
138.97 €
Cette collecte de dons se termine dans

Record d'assistance en ligne

Membres: 6 le 9 Apr 2024
Invités: 344 le 29 Mar 2024
Record d'assistance : 344 , le 29 Mar 2024

Visiteurs en ligne

Membres
0
Invités
9
Total
9

Statistiques du forum

Discussions
12 772
Messages
22 683
Membres
431
Dernier inscrit
Cleantalk
General chit-chat
Aides Utilisateurs
  • Personne ne discute en ce moment.
  • Richard Richard:
    Bon vendredi à tous et toutes, ciel gris ce matin avec 3c,,pluie prévue en pm ☔️ avec 12c,,qualif F1🏎️ ce soir à 22.30 ( heure du Québec ) sur le circuit de Shanghai,,,Bonne journée 😉😉
    • Bonjour
    Réactions: Marcel_By_MTR
  • leane64 leane64:
    Bonsoir tout le monde
    • Bonjour
    Réactions: Richard et Marcel_By_MTR
  • Marcel_By_MTR Marcel_By_MTR:
    @demain
  • Marcel_By_MTR Marcel_By_MTR:
    Bonjour T-E, bon week-end
    • Bonjour
    Réactions: Richard
  • Richard Richard:
    Bon samedi à tous et toutes,petit 3c et ciel mi bleu mi gris,,prévu de 8c en fin d’après-midi Bonne journée 😉😉
    • Bonjour
    Réactions: Marcel_By_MTR
  • Marcel_By_MTR Marcel_By_MTR:
    Une Q3 de vendredi tout en glissade. Un beau Sprint ce samedi surtout sur les trois derniers tours.
  • Richard Richard:
    Pauvre Norris,,tellement pressé de doublé Hamilton et s’est ramasser 6 ieme,,et les 2 Ferrari qui se font touchette,,,belle course sprint 😉😉
    • J'aime
    Réactions: Marcel_By_MTR
  • Richard Richard:
    Eh ben,Perez va donner du fil à retordre à Red Bull pour son contrat,,les Ferrari se sont heurtés à des Mc Laren en forme,,Hamilton est là où il faut (19 ieme ) 😉😉
    • J'aime
    Réactions: Marcel_By_MTR
  • Marcel_By_MTR Marcel_By_MTR:
    @demain
    • J'aime
    Réactions: Richard
  • Richard Richard:
    Bonne soirée
  • Richard Richard:
    Course F1cette nuit 😉😉
  • Marcel_By_MTR Marcel_By_MTR:
    Bonjour T-E, bon dimanche.
    • Bonjour
    Réactions: Richard
  • Marcel_By_MTR Marcel_By_MTR:
    Un grand prix pas très passionnant mais belle course quand même.
    • Bonjour
    Réactions: Richard
  • Maurice Maurice:
    Bonjour 😀
    • Bonjour
    Réactions: Richard et Marcel_By_MTR
  • Richard Richard:
    Bon dimanche à tous et toutes,frais ce matin avec 0c,,prévu de 7c en fin d’après-midi,,de la neige ❄️ prévu en soirée avec une chute des températures autour des -12c pour demain matin,,Bonne journée 😉😉
    • Bonjour
    Réactions: Marcel_By_MTR
  • Richard Richard:
    Verstappen🥂 domine,,Norris ;)a été chanceux,,Pérez (y)a fait une belle remonté mais Alonso🫅 a fait le spectacle-------Miami dans 2 semaines avec encore une course sprint Bonne journée ;)
    • J'aime
    Réactions: Marcel_By_MTR
  • T Tom_D:
    bonjour
    • Bonjour
    Réactions: Richard et Marcel_By_MTR
  • Marcel_By_MTR Marcel_By_MTR:
    @demain
  • Marcel_By_MTR Marcel_By_MTR:
    Bonjour T-E, bonne semaine 17. Météo toujours médiocre et fraîche pour la saison. 10 à 12° max pour toute la semaine.
    • Bonjour
    Réactions: Richard
  • Richard Richard:
    Bon lundi à tous et toutes,frisquet ce matin avec-11c ,,une petite neige ❄️ est tombée cette nuit (+- 1cm ) prévu de 0c en fin d’après-midi avec mi soleil 🌞 mi nuages ⛅️,,Bonne journée 😉😉
    • Bonjour
    Réactions: Marcel_By_MTR
  • Maurice Maurice:
    Bonjour 😌
    • Bonjour
    Réactions: Marcel_By_MTR et Richard
  • Marcel_By_MTR Marcel_By_MTR:
    @demain
      Marcel_By_MTR Marcel_By_MTR: @demain
      Retour
      Haut Bas