*Résolu* - Petit Soucis avec un Tableau excel

JavaScript est désactivé. Pour une meilleure expérience, s'il vous plaît activer JavaScript dans votre navigateur avant de continuer.

Domtous

Membre VIP
Membre
31/12/19
46
27
18
Bonjour,

j'ai un petit soucis avec une formule ou plutot quand je veux remplir en automatique avec la poignet de remplissage (coin inférieur droit d'une cellule)

voilà la formule: =SI(B43="";"";Glaspull!H23) et quand je la tire elle me fait =SI(B44="";"";Glaspull!H24) et =SI(B45="";"";Glaspull!H25)
alors que moi je voudrais : =SI(B43="";"";Glaspull!H23) et =SI(B44="";"";Glaspull!H23) et =SI(B45="";"";Glaspull!H23)

alors quelqu'un aurait une idée

 
Dernière édition:

jacques

Actif ***
Membre Major*
Membre VIP
Membre
1/5/20
582
690
93
France

Bonjour je ne suis pas un spécialiste de excel mais tu devrais trouver pas mal d'explication a la :
Avanquest.Mediaforma.Formation.Excel
le lien:
 

Domtous

Membre VIP
Membre
31/12/19
46
27
18
Bonjour je ne suis pas un spécialiste de excel mais tu devrais trouver pas mal d'explication a la :
Avanquest.Mediaforma.Formation.Excel
le lien:

Merci c'est gentil, cela fait encore beaucoup de lecture :) je vais encore attendre un peu quelqu'un auras peut-etre là réponse
 

Marcel_By_MTR

Membre honoraire
Membre du staff
Administrateur
Membre VIP
Membre
1/5/20
572
568
93
Belgique-Liège
Effectivement Domtous, le "#" ne solutionne pas ton cas, c'est pour cette raison que j'ai modifié ma réponse initiale
Tu dois utiliser le "$"
Exemple
H$23 si tu fixe la ligne 23
$H23 si tu fixe la colonne H
$H$23 si tu fixe la cellule H23
 
  • J'aime
Les réactions: ccford

Domtous

Membre VIP
Membre
31/12/19
46
27
18
Re bonjour,

Voilà un autre problème Excel toujours sur le même tableau
donc Glaspull!$H$23 me donne un résultat
Aujourd'hui (7/09/2020), je rentre des valeurs dans ce tableau et j'enregistre ces données
Demain (8/09/2020), j'ouvre ce même fichier enregistrer la veille , donc jusque là tout va bien. Je change la valeur Glaspull!$H$23 et là les résultats du 7/09/2020 change.

Comment puis-je garder ces résultats du 7/09/2020 alors que Glaspull!$H$23 à changer. il faut savoir que j'ai protégé la feuille pour éviter les mauvaises manipulations

j'espère que je me suis bien fait comprendre :)
 

Marcel_By_MTR

Membre honoraire
Membre du staff
Administrateur
Membre VIP
Membre
1/5/20
572
568
93
Belgique-Liège
Bonjour Domtous,
Il est impossible de répondre à ta question.
Si des valeurs changent en fonction d'une date, c'est qu'il y a dans ton tableau une formule ou une macros qui prend en compte cette variable.
Te dire laquelle et ou elle se trouve sans le fichier excel, cela relève de la voyance.
 

Domtous

Membre VIP
Membre
31/12/19
46
27
18
Merci de ta réponse

non les valeurs ne change pas par rapport à une date, c'est moi qui décide de changer la valeur Glaspull!$H$23 pour des raison spécifique (quantité n'est plus la même)

moi ce que je veux c'est enregistrée cette feuille et pouvoir la récupérer un jour ou 1 heure plus-tard avec les résultats sauvegardées et pouvoir changer Glaspull!$H$23 sans que cela change la sauvegarde faite 1 jour avant ou 1 heure avant (enregistrement automatique)
 

Marcel_By_MTR

Membre honoraire
Membre du staff
Administrateur
Membre VIP
Membre
1/5/20
572
568
93
Belgique-Liège
Forcément...
Si aujourd'hui tu crée ton fichier en introduisant des valeurs spécifiques et que tu les sauves
Si demain du ré-ouvre ce même fichier avec les valeurs du jour précédent.
Mais si tu les modifies et que tu re-sauve ton fichier modifié... Il écrasera l'ancien (avec les anciennes valeurs)

Solution:
Lundi- Tu ouvre ton fichier initial - Tu introduit les valeurs de lundi - Tu sauve en spécifiant un nom de fichier spécifique à lundi.
Mardi- Tu ouvre ton fichier initial - Tu introduit les valeurs de Mardi - Tu sauve en spécifiant un nom de fichier spécifique à Mardi.
et ainsi de suite.
Cette solution n'est serte pas pratique mais fonctionne.

Pour toute autre solution,
Il faudrait que tu donne quelque explication complémentaire et que je dispose du fichier initial.
-----------------------------------------------------------
En france, il me semble que vos compteurs sont liés au fournisseur et que le type de contrat est subordonné à une puissance théorique. Donc je suppose que ta demande est lié d'une manière ou d'une autre au rapport Puissance/Consommation.
 

Domtous

Membre VIP
Membre
31/12/19
46
27
18
Pour toute autre solution,
Il faudrait que tu donne quelque explication complémentaire et que je dispose du fichier initial.

je vais te donner une adresse pour que tu puisse télécharger le dossier. dossier personnel à garder pour toi bien-sur
 

Marcel_By_MTR

Membre honoraire
Membre du staff
Administrateur
Membre VIP
Membre
1/5/20
572
568
93
Belgique-Liège
Je me doute bien que ce fichier est réservé à ton usage exclusif.
 
Giganews Newsgroup