Problème avec l'USB 3 sous Windows 10 - La solution

JavaScript est désactivé. Pour une meilleure expérience, s'il vous plaît activer JavaScript dans votre navigateur avant de continuer.

Sylvain

Administrateur
Membre du staff
Administrateur
30/12/19
1 529
1 629
113
Montréal
www.tutoriaux-excalibur.com
Ça fait un bon bout de temps que je trainais un problème avec mes ports USB 3 avec une carte mère MSI 970 Gaming.

Le port avant ne fonctionnait pas et les ports arrière ne fonctionnaient qu'à moitié ou me déconnectait mon adaptateur WIFI.

Je me suis longtemps posé la question pourquoi ça arrivait et j'ai tenté à de multiples reprises d'installer le dernier pilote conçu pour Windows 8 et ça ne fonctionnait jamais.

J'ai alors pensé qu'il y avait un problème avec Windows 10 alors j'ai rétrogradé à une version antérieure, mais rien n'y fait, le problème subsiste toujours et empire avec le temps, si bien que je ne pouvais plus connecter mon dongle WIFI sur un port USB 3.0 ni mes clés USB.

MSI a cessé la production de pilote pour l'USB 3.0 pour les cartes Intel et AMD et aucun fabricant ne donne vraiment de solution à ce problème.

Je me suis donc tourné vers le bios car l'USB 3.0 requiert pour Windows 7 et 8 le pilote USB 3.0 VIA_XHCI_Driver_V4.90A

J'ai cru à une anomalie en regardant la configuration, car cela fonctionne sous Windows 7 et 8 mais pas sous Windows 10.

J'ai donc ouvert dans les paramètres avancés, la configuration USB

Ukg7yIB.jpg


Puisque le chipset de ma carte vidéo requiert un pilote XHCI et que ce pilote ne fonctionne pas sous Windows 10, j'ai tout de suite pensé à le désactiver

dTzSRkM.jpg


Puis, je me suis dit que si XHCI ne fonctionne plus, il devait en être de même pour le EHCI alors je l'ai également désactivé

ygR5BVP.jpg


J'ai ensuite appuyé sur la touche F10 de mon clavier pour sauvegarder la modification et redémarrer.

Et au redémarrage quelle ne fut pas ma surprise de voir que le pilote de Microsoft fournit via Windows update fonctionne parfaitement et que mes posts USB 3.0 se sont réanimés et ne présentent plus aucun symptôme.

Si cela peut en aider d'autres alors tant mieux.
 
Dernière édition:

Macadam

Actif *
Membre
20/1/20
165
211
43
Bonjour Sylvain,

Si tu désactives le XHCI, ton port USB 3 démarre comme un USB 2 jusqu'au moment où il a le pilote quand tu arrives sous Windows.
 
  • J'aime
Les réactions: Sylvain et Marcel_By_MTR

mathieu89

Membre
1/1/20
38
24
8
bonjour
j'avai eu le meme symptome sur un pc portable acer ou les port usb3 disparaisser tous seul
vaut mieux passer par quelqle chose qui fonctionne que de non fonctionnel
 
  • J'aime
Les réactions: Sylvain

Campagne de dons

Campagne 2021

Supporter TE en effectuant un petit don
Objectif
350.00 $
Reçu
192.38 $
Cette collecte de dons se termine dans